domingo, 22 de março de 2009

Problema, Não Aparece Ambiente Gráfico Após Instalar o Debian Lenny.

Se esta lendo esse guia bem provavelmente esta com problema de não aparecer o ambiente gráfico apos a instalação do Debian Lenny, aqui vou demostrar como resolver (possivelmente) os dois principais problemas nesse ponto, graça as dicas na web. :)
O Xorg antigamente tinha que na instalação configurar algumas coisas, tipo drive, resolução, coisas simples, mas na nova versão mudaram, se não me engano nessa versão, tornando ele automático.
Agora as pessoas vão aprendendo como fazer isso, conhecendo as ferramentas novas que fizeram para se ele errar no automático tenha um modo manual para isso, agora veja, nos meus dois computadores, desktop e notebook, reconheceu certinho, drive, resolução, etc..., infelizmente pode acontecer isso em alguns poucos casos, pelo que vi em Foruns sobre Debian, é um modo novo, logo nem poucos erros terá :).


Esse guia faz parte de
Debian Lenny 5.0, Instalação para Iniciantes, Notas e Informações de Lançamento.
http://flavioblogg.blogspot.com/2009/02/debian-lenny-50-instalacao-para.html


Verificar Instalação do Ambiente Gráfico.
Vamos pelo mais fácil, se instalou o ambiente gráfico

Teclar

Ctrl + Alt + F1

faça o login como usuário.


Veja se ele esta instalado, comando.

dpkg -l xorg

se aparecer esse resultado ele esta instalado, repare nos 2 i no começo (ii) isso indica que esta instalado.

||/ Nome Versão Descrição
+++-==============-==============-=
ii xorg 1:7.3+18 X.Org X Window System


Se não tiver instale o Debian Lenny de novo, é melhor, e preste atenção na parte que ele fala dos pacotes para instalar, ai tem ambiente gráfico e tem de estar marcado.

Olha ai as opções de pacotes (clique para aumentar a imagem)
Se tiver Notebook marque Laptop também.


Frequência acima do suportado pelo monitor
O monitor avisa sobre isso geralmente.

Teclas

Ctrl + Alt + (+)

ou

Ctrl + Alt + (-)


Dica de ☠☠™ΔŁ€ЖΔŇĐŘ€™☠☠
Finalizada, confirmada e acertada, Fernando
http://www.orkut.com.br/CommMsgs.aspx?cmm=9145&tid=5305238226470714355


Drive que o Xorg escolhe não é o apropriado.
Aqui ele configura (parece que com cuidado para evitar erro) e também gera um arquivo de configuração como antigamente, assim se precisar é só editar.

Feche o ambiente gráfico

De esse comando para ir para um terminal

Ctrl + Alt + F1

login como root

Se tiver kdm, ou gdm (onde se da a senha e login em modo gráfico), desative.
com esses comandos, como root.
/etc/init.d/gdm stop
/etc/init.d/kdm stop

Comando como root

Xorg -configure

ele no final, na ultima linha ele diz que para testar a configuração, de esse comando.

que seria esse
X -config /root/xorg.conf.new

de o comando que diz, veja se aparece o gráfico, vai aparecer apenas o cursor do mouse e uma tela tipo com uma imagem de tecido.
Se aparecer isso, ok ta funcionando, agora falta colocar no lugar.

Para sair dessa imagem.

Ctrl + Alt + F1

depois

Ctrl + C

Colocando no lugar, nessa ordem

fazer um backup do que tem, de esse comando.
mv /etc/X11/xorg.conf /etc/X11/xorg.conf-bkp

Colocando no lugar, de o comando
cp /root/xorg.conf.new /etc/X11/xorg.conf


Se tiver kdm, ou gdm (onde se da a senha e login em modo gráfico), agora precisa ativar eles.
Com esses comandos, como root.
/etc/init.d/gdm start
/etc/init.d/kdm start

Ok ta feito


Se não aparecer a imagem?
Se pode editar de forma simples o arquivo.

como root, esse comando
nano /root/xorg.conf.new

nessa parte, exemplo

Identifier "Card0"
Driver "nv"
VendorName "nVidia Corporation"
BoardName "G72M [GeForce Go 7400]"
BusID "PCI:5:0:0"

aqui se não funcionar, se pode colocar o drive generico, o vesa, que se coloca no lugar de nv que é de nvidia nesse exemplo.
Naturalmente ai pode estar indicando outro drive, dependendo do que ele detectou

fica assim, nesse exemplo.

Identifier "Card0"
Driver "vesa"
VendorName "nVidia Corporation"
BoardName "G72M [GeForce Go 7400]"
BusID "PCI:5:0:0"

Para salvar
Ctrl + O

Enter

Para fechar o programa (o programa esta em português e é relativamente fácil de usar)

Ctrl + X

agora repita os passos anteriores, da parte de testar a configuração, veja se aparece a mesma imagem, etc...

Olha uma pagina que informa os drives do Xorg, os nomes dos drives pelo que vejo, pode ter drive ai que aqui não tenha, pois pode ser o drive de versão mais nova que o drive que esta no debian lenny, ou outro motivo qualquer.
http://www.x.org/wiki/Projects/Drivers?action=show&redirect=VideoDrivers


Dica de André Luís Lopes
http://groups.google.com.br/group/linux.debian.user.portuguese/browse_thread/thread/da306d6fe37c5c32?hl=pt-BR#


Resolução Ajustar

Ajuste no ambiente gráfico, no kde

em Menu, Centro de Controle, Periféricos, Tela

No Gnome de uma procurada



Atualizada em 26/03/2009

adic. Resolução Ajustar, e pequenos ajustes

8 comentários:

Denis Fernandes disse...

opa, jóia. este problema está acontecendo comigo, instalei o debian 5 cd com kde, quando inicio o x abre uma tela com o papel de parede do debian e tem o gerenciador de janelas TWM, sendo que instalei com o kde.

Como faço para resolver isso? meu e-mail denis200596 [arroba] hotmail.com

Evandro disse...

Perfeita explicação...


Obrigado !!!

Flávio disse...

Tava Viajando.

Denis Fernandes, me coloca o link de onde pegou a image iso, e do arquivo que pegou para instalar o debian, estranho isso.

Flávio disse...

Evandro

Obrigado :)

ricardo disse...

cara foi dificil mas seguindo passo a passo consegui.

vc nao tem nada como sobre instalar driver nvidia no debian


obrigado!

Flávio disse...

Olha
http://flavioblogg.blogspot.com/2009/03/instalar-drive-da-nvidia-no-debian.html

Para ver todos os post, no menu do lado direito, clica em Paginas do Blog (Índice).

Eng.º Rafael Ferreira disse...

Flavio .. como ativo para ambiente grafico o root .. so consigo logar com o meu user

Flávio disse...

Sou da opinião que ambiente gráfico se usa apenas em modo usuário.

Mas você pode usar os programas que precisar como root, apenas o que realmente precisar, assim.

no terminal

kde

kdesu programa

gnome

gksu programa


exemplo

kdesu kwrite