sábado, 14 de novembro de 2009

Instalar Amsn 0.98.1 no Debian Lenny 5.0

Aqui vou mostrar como instalar o Amsn no Debian via pacote oficial dele.
Para quem não conhece ele é bem interessante, ele tem envio de Clip de Voz, Chamada de Vídeo, Ligação, Mensagem Offline, entre outros recursos
Ele é bem configurável, tem muitas opções para quem gosta de configurar o programa, se de alguma coisa não gostar ou alguma coisa que queira que ele tivesse, veja se já não tem, vendo e conhecendo o programa e suas opções de configuração.




IMPORTANTE
No Amsn 0.98.3 teve algumas mudanças, entre elas o pacote .package foi retirado, a conferencia (áudio e vídeo) também foi retirada, entre outras coisas, pelo que entendi basicamente por causa da mudança de protocolo para o MSNP18 isso pela microsoft, assim ainda não esta pronto o amsn para esse protocolo, parece que foi uma mudança rápida assim os desenvolvedores não esperavam.
Olha testei aqui a versão 0.98.1, testei assim amsn para amsn, testei conectar desconectar algumas vezes, mudanças de estados, mensagens, mensagens offline, winks, emoticon simples), pedido de atenção, bloquear/desbloquear, mais algumas coisas que não lembro, tudo funcionou direitinho, faltou testar amsn para msn, mas na rede do msn funcionou tudo certinho.
Também dei uma olhada nos buscadores por problemas no amsn 0.98 no linux, e não encontrei nada, apenas problemas normais e no fórum do amsn para linux, também nada.
Caso encontre algum problema informe usando o comentário aqui.

Como já disse, foi retirado o pacote .package, esse pacote era um tipo de universal para linux, de fácil instalação, parece que o projeto do pacote não esta bem, mas não é de agora que eles(amsn) disponibilizavam os pacotes de instalação fácil (binários), em Copie o Amsn no link para a versão 0.98.1 la tem as versões se pode ver isso, assim acredito que depois de colocar o suporte a MSNP18 eles voltem a fazer.
Sobre o autopackage, o projeto do pacote .package nos links
http://code.google.com/p/autopackage/
http://www.autopackage.org/



Dependências

Instale as dependências necessárias para rodar o Amsn

aptitude install bzip2 tcl tk8.5 tcl-tls sox cabextract gnash libsnack2


Copie o Amsn

Para a versão 0.98.1 que o guia explica o link abaixo, pegue o pacote amsn-0.98.1-1.tcl85.x86.package
http://sourceforge.net/projects/amsn/files/
http://sourceforge.net/projects/amsn/

http://www.amsn-project.net/
No menu Downloads, Linux, aMSN Installer for Tcl/Tk 8.5


Dando permissão de execução ao arquivo

Quando copiar ele todo, de permissão de execução no arquivo.
No kde com o gerenciador de arquivos, selecione o arquivo, clique botão direito, em propriedades clique.
Ai selecione a aba Permissões, ai tem um opção chamada, É Executável, marque ele, de ok. (isso funciona em qualquer gerenciador de arquivos, apenas muda um pouco, a permissão deve ficar assim, -rwxr-xr-x )


Instalação

Esteja conectado a Internet.
Clique no arquivo, ai abre um terminal, é onde ele vai copiar pela internet o programa de instalação o autopackage, nessa tela de enter

Quando terminar de copiar ele abre uma tela para colocar o Password, ai você pode tanto instalar como root, ou como usuário, para instalar como root, coloque a senha root e de Continue, para instalar como usuário clique em No Password.
Veja, o programa não pode ficar instalado como usuário isso é apenas para pessoas mais avançadas, que depois pegam o diretório do programa e mudam de lugar e de permissão de acesso.

Agora ele vai instalar o instalador quando terminar vai aparecer a mensagem no terminal Press Enter to close this window, ai tecle enter no terminal.

Agora começa a instalação do amsn.

Quando a tela mudar para Installation completed, de ok

Amsn instalado :)
Vai no menu internet e clique nele.


Se aparecer esse Problema

Problema se o amsn não abrir e aparecer essa mensagem
There's a problem loading a module of aMSN (TKCxImage):couldn't load file
utils/TkCximage/TkCximage.so

Você deve ter os dois tk o tk8.5 e o tk8.4

Para resolver isso, no terminal como root.

update-alternatives --config wish

Vai aparecer as versões disponíveis, escolha a /usr/bin/wish8.5, Quando aparecer as opções ele coloca um numero para cada opção na coluna Seleção, escolha o numero da opção desejada e de enter.

Fontes
http://ubuntuforums.org/showthread.php?t=753061
http://www.botecodigital.info/linux/instalar-firefox-no-debian-lenny/


Configurar o Amsn

Configurar o Nudge (Pedido de atenção)

Menu, Conta, Selecionar plugins, Nudge

Agora clique em Configurar

Marque

Chacoalhar a Janela ao receber um pedido de atenção
Tempo minimo entre pedidos de atenção vindos do mesmo contato coloque 30

Agora clique em Salvar

São as configurações padrão e como uso basicamente também, naturalmente você pode deixar como gostar.


Configurar Winks (para ver eles)

Menu, Conta, Selecionar plugins, Winks

Agora clique em Configurar

em Comando do player swf, coloque

gnash

clique em Salvar


Preferencias Locais

Menu, Conta, Preferências, Pessoal

em Preferências locais

colocar a do seu país no brasil pt-br

clica em Salvar


Mudar Aparência (Skin)

Se você quer uma aparência mais msn tem skin para isso, o aMSN Vista Futurosoft por exemplo.

Para escolher um skin (aparência)
http://www.amsn-project.net/skins.php

Instalar

Descompacta o arquivo do skin, por exemplo no aMSN Vista Futurosoft ele vem nesse pacote, aMSN_Futurosoft-1.1.zip, quando descompactado, vai ter um diretório o Futurosoft, pegue o diretório e coloque.

Para o seu usuário
em seu diretório de usuário, exemplo se meu usuário tivesse login eddie, seria /home/eddie/.amsn/skins

em seu diretório de usuário/.amsn/skins

feche o amsn e abra ele novamente.

Escolhendo uma aparência Skin

Menu, Conta, Skin selecionada

Selecione a que quer, clique em Ok


Plugins

Se pode colocar também plugins nele, pelo que vi, é como no Mudar Aparência (Skin), o que muda apenas é onde se coloca ele, no caso dos plugins é no diretório plugins.

Para o seu usuário
em seu diretório de usuário, exemplo se meu usuário tivesse login eddie, seria /home/eddie/.amsn/plugins

em seu diretório de usuário/.amsn/plugins

Um exemplo o SpellCheck, ele verifica se o que se escreve esta certo e marca os que tiverem errado, dando uma lista de possibilidades de palavras corretas, também se pode configurar ele.
Para que esse plugin funcione precisa instalar o aspell correspondente a sua lingua.

Brasil, comando como root

aptitude install aspell aspell-pt-br

Portugal, comando como root

aptitude install aspell aspell-pt-pt

Pagina dos Plugins
http://www.amsn-project.net/plugins.php

Para configurar os Plugins

Menu, Conta, Selecionar plugins


Áudio e Microfone (Clip de Voz), Conferência de Áudio e Vídeo

O áudio tanto som como microfone funcionaram, mas o microfone infelizmente ficou com um pouquinho de chiado, mas precisa desligar o sistema de som do ambiente gráfico que fica ocupando a porta de som, ou depois de um tempo sem som, ele se desativa.

A Conferência de Áudio e Vídeo infelizmente como é novo ainda não tem no debian Lenny, parece que tem no backport, mas pelo que vi é para experientes.

O necessário para Conferência de Áudio e Vídeo
http://www.amsn-project.net/wiki/Farsight

Para configurar Webcam, Áudio e Microfone (Clip de Voz), Conferência de Áudio e Vídeo.

Menu, Conta, Preferências, Outros, em Configuração de Áudio e Vídeo, Editar opções de áudio e vídeo.


Imagens do Amsn 0.89.1, aparência oficial
Se pode mudar a imagem dele com skin, falo sobre isso acima em Mudar Aparência (Skin)





Atualizado em 11/03/2010

adic. informação sobre a versão 0.98.3 e mudanças, e teste e link para a versão 0.98.1

28/11/2009

adic. a parte Plugins.

14/11/2009
Adic. dependência de áudio e microfone (Clip de Voz) (instale de novo as dependências na parte Dependências) adic. a parte Áudio e Microfone (Clip de Voz), Conferência de Áudio e Vídeo.

3 comentários:

jb disse...

Olá Flavio,então eu tenho o insigne momentum ele vem com o amsn,a primeira versão eu já atualizei uma vez pelo synaptic,mais agora ñ tem mais atualizações,e o amsn ñ quer entra mais,e ele mostra que tem a nova versão...
mais ñ consigo instalar melhor dizendo ñ sei como instalar sou novo no linux rs..
será que vc pode me mostrar como que eu posso instalar pq é meio complicado instalar no programas no linux!!
obrigado espero resposta abraço !!!

Flávio disse...

Instalar pelo amsn não sei como é não, nunca tentei.
Se ele não abre mais, desinstala ele pelo synaptic e instala de novo.
Se eu não me engano o insigne é baseado em debian, não tenho certeza, se for, pode fazer assim como demostro aqui, antes retire o amsn que esta instalado ai.

jb disse...

Ele está abrindo normal,só que ñ estava logando... sim,ele é em debian também eu fiz aquele procedimento que vc demostra aqui deu certo,mais deu aquele erro que vc cita,só que ñ sei entrar em modo root ..mais já resolvi o problema vlw obriagod por responder!!